Missing Data in XRef Table AIA 2.0.X and SOA 10.1.3.5 After Patch # 9247257 (Doc ID 1380119.1)

Last updated on OCTOBER 04, 2016

Applies to:

Oracle Application Integration Architecture Foundation Pack - Version 2.0.1 to 2.5 [Release 2]
Information in this document applies to any platform.

Goal

It is observed that the XRefTool 10.1.3.5 will not work correctly in combination with AIA 2.0.x

As part of AIA 2.0.x installation, inside standard Oracle AIA ant scripts responsible for installation and deployment of AIA there is a step which import data from standard AIA files to Xref table.

The analysis has showed that this step is defined at: XrefInstall.xml ($AIA_HOME/install/scripts/XrefInstall.xml). As part of this file, the xreftool.sh is used to import data to the table.

It is observed that the xref tool works correctly in 10.1.3.3 in combination with AIA 2.0.x, but not in 10.1.3.5 in combination with the same AIA 2.0.x version, as it raises the following result:

[exec] [exec]
[exec] [exec] Please enter OC4J username and password
[exec] [exec]

According to validations for the current issue, it is suggested to apply the Patch # 9247257 - 'XREF TABLES ARE NOT GETTING CREATED AFTER THE PIP INSTALLATION IN 10.1.3.5 FMW'. However, just applying the patch does not solve the creation of the missing data in the XRef tables for an environment with AIA 2.0.X already installed.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms