EM 12c, EM 13c: Enterprise Manager Cloud Control OMS Installation Fails At Plugins Prerequisites Check With Message: Error while resolving dependencies: Cannot resolve dependency (Doc ID 1390815.1)

Last updated on DECEMBER 02, 2015

Applies to:

Enterprise Manager Base Platform - Version 12.1.0.1.0 and later
Generic UNIX
Checked for relevance on 09-Jul-2014

Symptoms

OMS Installation fails at plugins prerequisites check stage

From <CENTRAL_INVENTOTY_HOME>/logs/installActions*.log

========================

INFO: oracle.sysman.top.oms:Initializing PluginCA.
INFO: oracle.sysman.top.oms:Error while resolving dependencies: Cannot resolve dependency. oracle.sysman.db for plugin oracle.sysman.xa : 12.1.0.1.0 No connection could be obtained. In case this is expected and prereq check is being done, dependent plugins should be passed to PluginCA
INFO: oracle.sysman.top.oms:Diagnostic log file: /u01/app/oracle/Middleware/oms/cfgtoollogs/pluginca/plugin_deployment_2011-12-20_11-29-23/configplugin_prereq_check_2011-12-20_11-29-23.log
INFO: oracle.sysman.top.oms:For help type pluginca -help
INFO: oracle.sysman.top.oms:The plug-in Plugins Prerequisites Check has failed its perform method

========================

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms