Users/Groups From Custom Authentication Provider Not Showing Up In Fusion Middleware Control Application Roles Creation (Doc ID 1491292.1)

Last updated on MARCH 09, 2017

Applies to:

Enterprise Manager for Fusion Middleware - Version 11.1.1.1.0 to 11.1.1.6.0
Information in this document applies to any platform.

Symptoms

Users and groups from custom authenticators do not display in Enterprise Manager Fusion Middleware Control 11g(fmwc) when creating Application Role for "Application deployments".

Implemented custom authentication in WLS and confirmed that users and groups from the custom authenticator can be displayed with following two methods.

a. Displayed under WLS console Security Realm's "users and group" tab.

b. Users are confirmed to exist in fmwc System mbean browser:
    Runtime mbeans > Security > Domain: base_domain > myrealmDefaultAuthenticator > userExists / groupExists


Create "Application Roles" in fmwc does not display the custom authenticator's users and groups.  Only users/groups from default authenticator are displayed.
Following is breadcrumbs to reproduce the issue in fmwc: 

fmwc > Farm > Application deployment > Select an application (eg. myApplication)
 > RightClick: Security > Application Roles
  > Search/Application Stripe: Select a value from dropdown box
   > Create > Add > Type: Select user or group
    > Search: Click Blue button

Changes

Installed file base custom authentication provider and created users and groups for this custom authenticator.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms