Accessing the 11g Database Control URL Results in Error: Service is not initialized correctly. OMS version 10.2.0.4.2 is not compatible with repository version 10.2.0.4 (Doc ID 1627015.1)

Last updated on FEBRUARY 24, 2014

Applies to:

Enterprise Manager for Oracle Database - Version 11.1.0.1 to 11.2.0.4 [Release 11.1 to 11.2]
Information in this document applies to any platform.

Symptoms

Opening the 11.2.0.3 Database Control (dbconsole) URL in a browser shows the following error:

503 Service Unavailable
Service is not initialized correctly. OMS version 10.2.0.4.2 is not compatible with repository version 10.2.0.4.4

The error message implies that the OMS version (which dbconsole is built around) and the repository version are not compatible.  However the command 'emctl status agent' shows the correct  (10.2.0.4.4) OMS  version.  For example:- 

Oracle Enterprise Manager 11g Database Control Release 11.2.0.3.0
Copyright (c) 1996, 2011 Oracle Corporation.  All rights reserved.
---------------------------------------------------------------
Agent Version     : 10.2.0.4.4
OMS Version       : 10.2.0.4.4
Protocol Version  : 10.2.0.4.4

 And this matches with the dbconsole repository version.  For example:-

SQL> select version from mgmt_versions where component_name='CORE';

VERSION
--------------------------------
10.2.0.4.4

If a brand new database is created in the same Oracle Home, and dbconsole is configured for this new database, the same error is given when accessing the dbconsole URL.  

Changes

 The database was upgraded from 10.2.0.4 to 11.2.0.1 and then to 11.2.0.3.  The 11.2.0.3 rdbms software was installed in a new separate home.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms