My Oracle Support Banner

Em12c: Rollback of Weblogic PSU patches through EM corrupts config.xml file ( Admin Server Startup fails with Schema validation errors ) (Doc ID 2005169.1)

Last updated on MAY 07, 2018

Applies to:

Enterprise Manager for Fusion Middleware - Version 12.1.0.5.0 to 12.1.0.7.0
Information in this document applies to any platform.

Symptoms

When using the Rollback feature of the Cloud Control for the Weblogic Targets like ( SOA/Web Center/IDM/OBIEE/OSB ) etc , the file config.xml gets corrupted and the Admin Server will fail to start.

When trying to rollback PSU2+(x) using the cloud control the patch plan fails at the step "Start Admin Servers"
Looking at the startup log [...]/gc_inst/user_projects/domains/GCDomain/servers/EMGC_ADMINSERVER/logs shows that there is corruption in the config.xml file.

 

####<Apr 29, 2015 3:32:19 AM MDT> <Error> <Management> <test> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1430299939165> <BEA-141244> <Schema validation errors while parsing /u02/app/Oracle/Middleware/user_projects/domains/OSB1116/config/config.xml - Expected elements 'staging-mode@http://xmlns.oracle.com/weblogic/domain alt-descriptor-path@http://xmlns.oracle.com/weblogic/domain alt-wls-descriptor-path@http://xmlns.oracle.com/weblogic/domain application-identifier@http://xmlns.oracle.com/weblogic/domain application-name@http://xmlns.oracle.com/weblogic/domain' instead of 'cache-in-app-directory@http://xmlns.oracle.com/weblogic/domain' here in element app-deployment@http://xmlns.oracle.com/weblogic/domain>
####<Apr 29, 2015 3:32:19 AM MDT> <Error> <Management> <test> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1430299939166> <BEA-141244> <Schema validation errors while parsing /u02/app/Oracle/Middleware/user_projects/domains/OSB1116/config/config.xml - Expected elements 'alt-descriptor-path@http://xmlns.oracle.com/weblogic/domain alt-wls-descriptor-path@http://xmlns.oracle.com/weblogic/domain application-identifier@http://xmlns.oracle.com/weblogic/domain application-name@http://xmlns.oracle.com/weblogic/domain' instead of 'cache-in-app-directory@http://xmlns.oracle.com/weblogic/domain' here in element app-deployment@http://xmlns.oracle.com/weblogic/domain>
####<Apr 29, 2015 3:32:19 AM MDT> <Error> <Management> <test> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1430299939166> <BEA-141244> <Schema validation errors while parsing /u02/app/Oracle/Middleware/user_projects/domains/OSB1116/config/config.xml - Expected elements 'alt-descriptor-path@http://xmlns.oracle.com/weblogic/domain alt-wls-descriptor-path@http://xmlns.oracle.com/weblogic/domain application-identifier@http://xmlns.oracle.com/weblogic/domain application-name@http://xmlns.oracle.com/weblogic/domain' instead of 'cache-in-app-directory@http://xmlns.oracle.com/weblogic/domain' here in element app-deployment@http://xmlns.oracle.com/weblogic/domain>

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.