EM 12c: Associating Patch 22248372 to Targets in Enterprise Manager 12c Cloud Control Patch Plan Results in Error: It Renders the Patch Plan as non-deployable: Expected version not supported. (Doc ID 2112912.1)

Last updated on JUNE 08, 2016

Applies to:

Enterprise Manager Base Platform - Version 12.1.0.4.0 and later
Enterprise Manager for Fusion Middleware - Version 12.1.0.7.0 and later
Information in this document applies to any platform.

Symptoms

Applying patch 22248372 for WEBLOGIC SERVER CVE-2015-4852 SECURITY ALERT PATCH (NOV 2015) in Enterprise Manager (EM) 12.1.0.4 Cloud Control Patches & Updates results in one of these errors:

Reason: It renders the plan as non-deployable. : Expected version not supported. Supported versions are 10.3.x, found 10.3.6.0.12

Reason: It renders the plan as non-deployable. : Expected version not supported. Supported versions are 10.3.x, found 12.1.3.0.5

In EM 12.1.0.3 and earlier, this message was given because deployment of certain patches was not supported, but, beginning with EM 12.1.0.4 Cloud Control, deployment of WLS patches should be possible.

The following graphic shows the EM 12.1.0.4 Cloud Control console view of the error:

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms