EM 12c: Applying Enterprise Manager 12.1.0.5 Cloud Control OMS Patch 22882942 Fails: ORA-20102: Patch Pre-req failed, Repository version 12.1.0.5.0 is not compatible with the version of 1 OMS (Doc ID 2130187.1)

Last updated on MAY 14, 2016

Applies to:

Enterprise Manager Base Platform - Version 12.1.0.5.0 to 12.1.0.5.0 [Release 12.1]
Information in this document applies to any platform.

Symptoms

Enterprise Manager (EM) Cloud Control OMS : 12.1.0.5.0
EM 12.1.0.5 System Patch 22882942: Enterprise Manager for oms plugins 12.1.0.5.160331

Application of <Patch 22882942> fails with the following message:

ORA-20102: Patch Pre-req failed, Repository version 12.1.0.5.0 is not compatible with the version of 1 OMS

From .../Middleware/oms/.opatchauto_patch_storage/oms_session/oms_session_log_<date_time>.log:

ORA-20102: Patch Pre-req failed, Repository version 12.1.0.5.0 is not compatible with the version of 1 OMS(s)
ORA-06512: at "SYSMAN.MGMT_PATCH_UTIL", line 148
ORA-06512: at line 5
File:/u1/app/Middleware3/oms/sysman/emdrep/config/patch/sql/patchPreApply.sql
Statement:DECLARE

BEGIN

MGMT_PATCH_UTIL.MGMT_PATCH_PRE_CHECKS(MGMT_PATCH_UTIL.G_PATCH_MODE_APPLY);

END;

 

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms