My Oracle Support Banner

EM 13c: Patching the Enterprise Manager 13c Cloud Control OMS Fails with Error: WARNING: OMSPatcher finds that no sub-patch(es) can be applied to the OMS system (Doc ID 2199697.1)

Last updated on APRIL 30, 2018

Applies to:

Enterprise Manager Base Platform - Version 13.1.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Running "omspatcher apply -analyze" on the Enterprise Manager (EM) 13.1.0.0.0 Cloud Control OMS fails with this session error:

$ omspatcher apply -analyze
OMSPatcher Automation Tool
Copyright (c) 2015, Oracle Corporation. All rights reserved.

OMSPatcher version : 13.6.0.0.1
OUI version : 13.6.0.0.0
Running from : /u01/app/oracle/em/middleware
Log file location : /u01/app/oracle/em/middleware/cfgtoollogs/omspatcher/opatch2016-10-14_16-08-12PM_1.log

OMSPatcher log file: /u01/app/oracle/em/middleware/cfgtoollogs/omspatcher/23134365/omspatcher_2016-10-14_16-08-18PM_analyze.log

Please enter OMS weblogic admin server URL(t3s://uk-yo-dbmon02.cpp-group.com:7102):>
Please enter OMS weblogic admin server username(weblogic):>
Please enter OMS weblogic admin server password:>

WARNING: Could not apply the patch "23134365" because the "oracle.sysman.top.oms with version 13.1.0.0.0" core component of the OMS or the plug-in for which the patch is intended is either not deployed or deployed with another version in your Enterprise Manager system.
WARNING: OMSPatcher finds that no sub-patch(es) can be applied to the OMS system.

Complete Summary
================

Prerequisites analysis summary:
-------------------------------
The following sub-patches are incompatible with components installed in the OMS system:
23134365

--------------------------------------------------------------------------------
The following warnings have occurred during OPatch execution:
1) Could not apply the patch "23134365" because the "oracle.sysman.top.oms with version 13.1.0.0.0" core component of the OMS or the plug-in for which the patch is intended is either not deployed or deployed with another version in your Enterprise Manager system.
2) OMSPatcher finds that no sub-patch(es) can be applied to the OMS system.
--------------------------------------------------------------------------------

OMSPatcher Session completed with warnings.
Log file location: /u01/app/oracle/em/middleware/cfgtoollogs/omspatcher/23134365/omspatcher_2016-10-14_16-08-18PM_analyze.log

OMSPatcher completed with warnings.

 

Changes

OPatch has been upgraded to 13.9.1.0.0 in the EM 13c OMS Oracle Home.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.