EM 13c: Enterprise Manager Cloud Control OMS Upgrade to 13c Fails with Error: Compatible software to upgrade the plug-ins is not available

(Doc ID 2340477.1)

Last updated on JANUARY 02, 2018

Applies to:

Enterprise Manager Base Platform - Version 13.2.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Enterprise Manager Cloud Control OMS upgrade from 12.1.0.5 to 13.2


Upgrading the EM Cloud Control OMS with plug-ins to 13.2 using the software only method with the graphical installer interface fails with the following logged error:

2017-12-08 11:35:01,673 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - calling query: executeSql
2017-12-08 11:35:01,674 OFF   [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger -       arg: sysman
2017-12-08 11:35:01,674 OFF   [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger -       arg: *Protected value, not to be logged*
2017-12-08 11:35:01,674 OFF   [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger -       arg: select plugin_id||':'||plugin_name from gc_current_deployed_plugin where destination_type = 'Repository'
2017-12-08 11:35:01,674 OFF   [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger -     connecting to database with already created connect string
2017-12-08 11:35:01,730 OFF   [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger -       return value: oracle.sun.oss7:Oracle ZFS Storage Appliances,oracle.sysman.vi:Oracle Virtual Infrastructure,oracle.sysman.beacon:Oracle beacon,oracle.sysman.csa:Oracle CSA,oracle.sysman.emrep:Management Services and Repository,oracle.sysman.oh:Oracle Home,oracle.sysman.vt:Oracle Virtualization,oracle.sysman.mos:Oracle MOS (My Oracle Support),oracle.sysman.cfw:Oracle Cloud Framework,oracle.sysman.emas:Oracle Fusion Middleware,oracle.sysman.db:Oracle Database,oracle.sysman.xa:Oracle Exadata,oracle.oud.odir:Oracle Unified Directory,oracle.em.sehc:Oracle Engineered System Healthchecks,oracle.dba.odba:Oracle Database Appliance,oracle.em.sooc:Oracle Ops Center Infrastructure stack,oracle.sun.ossb:Oracle Hardware

017-12-08 11:35:01,732 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - POPUP ERROR:The following plug-ins that are deployed on your existing Enterprise Manager system are not compatible with the Enterprise Manager release you are about to upgrade to, and the compatible software to upgrade the plug-ins is not available at the moment.
Oracle Unified Directory(oracle.oud.odir)
Oracle Database Appliance(oracle.dba.odba)

Exit the wizard, download the compatible software for these plug-ins, and then invoke the installer by passing "PLUGIN_LOCATION=<absolute_path_to_plugin_archives_location>".
2017-12-08 11:35:22,648 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - Other checks for upgrade
2017-12-08 11:35:22,649 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - b_skipStandByOMSValidation flag value is false
2017-12-08 11:35:22,649 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - b_skipAgtVersionCheck flag value is false
2017-12-08 11:35:22,649 INFO  [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - b_skipAgtPatchCheck flag value is false
2017-12-08 11:35:22,650 SEVERE [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - getTextLogger is not supported
2017-12-08 11:35:22,675 SEVERE [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - getTextLogger is not supported
2017-12-08 11:35:22,676 SEVERE [25] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - getTextLogger is not supported
2017-12-08 11:35:23,909 INFO  [16] oracle.sysman.oii.oiio.oiiol.OiiolTextLogger - POPUP WARNING:Do you really want to exit?
2017-12-08 11:35:26,125 INFO  [16] oracle.sysman.oii.oiic.OiicAPIInstaller - Update the state machine to STATE_CLEAN

 

 

The corresponding pop-up window error shows in the EM 13.2 upgrade installer session:

 

 

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms