My Oracle Support Banner

OMS Upgrade Failed with Invalid objects found at Repository side (Doc ID 2585812.1)

Last updated on APRIL 27, 2020

Applies to:

Enterprise Manager Base Platform - Version 13.2.0.0.0 and later
Information in this document applies to any platform.

Symptoms

During OMS upgrade, plugin prereq step failed with below error

$OMS_HOME/cfgtoollogs/cfmfw/CfmLogger_<timestamp>.log

INFO: oracle.sysman.top.oms:Starting Prereq check..
INFO: oracle.sysman.top.oms:EM-04101: Following invalid objects are found in EM repository:  
INFO: oracle.sysman.top.oms: PACKAGE BODY : CSP_CERTIFICATION
INFO: oracle.sysman.top.oms:. Retry plug-in deployment after recompiling all invalid objects.
INFO: oracle.sysman.top.oms:EM-04014: Server-side plug-in deployment failed. Some prerequisite checks failed previously. Plug-in deployment cannot continue. Contact Oracle Support
INFO: oracle.sysman.top.oms:Diagnostic log file: $OMS_HOME/cfgtoollogs/pluginca/gcupgrade/configplugin_prereq_check_2019-09-06_05-40-19.log
INFO: oracle.sysman.top.oms:For help type pluginca -help
INFO: oracle.sysman.top.oms:The plug-in Plugins Prerequisites Check has failed its perform method

 

$OMS_HOME/cfgtoollogs/pluginca/configplugin_prereq_check_2019-09-06_05-40-19.trc

2019-09-06 05:40:29,411 [main] ERROR pluginca.PluginCADriver - EM-04014: Server-side plug-in deployment failed. Some prerequisite checks failed previously. Plug-in deployment cannot continue. Contact Oracle Support
oracle.sysman.core.common.extensibility.pluginca.PluginCAException: EM-04014: Server-side plug-in deployment failed. Some prerequisite checks failed previously. Plug-in deployment cannot continue. Contact Oracle Support
at oracle.sysman.core.common.extensibility.pluginca.PluginCA.preqreqCheck(PluginCA.java:889)
at oracle.sysman.core.common.extensibility.pluginca.PluginCA.configure(PluginCA.java:373)
at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.initPluginCA(PluginCADriver.java:2323)
at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.beginConfig(PluginCADriver.java:1274)
at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.main(PluginCADriver.java:2595)
Caused by: oracle.sysman.core.common.extensibility.pluginca.PluginCAException: EM-04101: Following invalid objects are found in EM repository:  
PACKAGE BODY : CSP_CERTIFICATION
. Retry plug-in deployment after recompiling all invalid objects.
at oracle.sysman.core.common.extensibility.pluginca.PreDeploySanityChecker.run(PreDeploySanityChecker.java:82)
at oracle.sysman.core.common.extensibility.pluginca.PluginCA.preqreqCheck(PluginCA.java:848)

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.