My Oracle Support Banner

EM Fleet Maintenance: Upgrade From 12c To 18c: Prerequisite Check Failed with "Unable to validate that the source database is not the Enterprise Manager repository" (Doc ID 2593096.1)

Last updated on JANUARY 01, 2020

Applies to:

Enterprise Manager for Oracle Database - Version 13.3.2.0.0 and later
Information in this document applies to any platform.

Symptoms

While trying to Upgrade Database fromtarget from 12.1.0.2 to 18.5 version using Enterprise Manager's Fleet Maintenance, it failed with below prerequisite error.

$ emcli db_software_maintenance -performOperation -name="Upgrade" -purpose=UPDATE_DB -target_type=oracle_database -target_list=<TargetDB-Name> -normal_credential="<HOST-CREDENTIAL-NAME>:SYSMAN" -privilege_credential="<privilege-credential-name>:SYSMAN" -database_credential="<database-credential-name>:SYSMAN"

Job Name: DB_UPGRADE_JOB_PREREQ

Step Name: preReq
Step Status: Failed
Start Time: 18/09/2019 12:20:09
End Time: 18/09/2019 12:20:09
Job OutPut:
Performing pre-requisite checks.
Unable to validate that the source database is not the Enterprise Manager repository.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.