My Oracle Support Banner

13.4: Patching OMS With the Plugin Update Patch Fails With Error: OMSPatcher failed with error code 238 (Doc ID 2658429.1)

Last updated on MARCH 26, 2021

Applies to:

Enterprise Manager Base Platform - Version 13.4.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Patching the 13.4 OMS with the Plugin Update patch fails with the error:

WARNING: Could not apply the patch "30971925" because the "oracle.sysman.bda.oms.plugin with version 13.4.1.0.0" core component of the OMS or the plug-in for which the patch is intended is either not deployed or deployed with another version in your Enterprise Manager system.

Configuration Validation: Success

Running apply prerequisite checks for sub-patch(es) "30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124" and Oracle Home "/refresh1/OEM134"...

Prerequisite checks FAILED for sub-patch(es) "30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124".

Complete Summary
================

All log file names referenced below can be accessed from the directory "<OMS_HOME>/cfgtoollogs/omspatcher/2020-04-12_14-21-56PM_SystemPatch_30895878_1"

Patching summary:
-----------------

The following sub-patch(es) are not applicable:

Featureset Sub-patches Log file
---------- ----------- --------
oracle.sysman.top.oms 30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124 30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124_opatch2020-04-12_14-22-11PM_1.log

The following sub-patches are incompatible with components installed in the OMS system:
30971925

[ Error during Run sub-patch(es) binary prerequisite checks Phase]. Detail: Some of the prerequisite checks to apply or rollback the patch(es) have failed.
OMSPatcher failed: OMSPatcher failed to validate some or all of patches binary prerequisite checks. Please refer log file(s) for more details.
--------------------------------------------------------------------------------
The following warnings have occurred during OPatch execution:
1) Could not apply the patch "30971925" because the "oracle.sysman.bda.oms.plugin with version 13.4.1.0.0" core component of the OMS or the plug-in for which the patch is intended is either not deployed or deployed with another version in your Enterprise Manager system.
--------------------------------------------------------------------------------
Log file location: <OMS_HOME>/cfgtoollogs/omspatcher/30895878/omspatcher_2020-04-12_14-22-12PM_deploy.log

Recommended actions: Please refer log file(s) for more details on the errors. Please contact Oracle Support.

OMSPatcher failed with error code 238

 

<OMS_HOME>/cfgtoollogs/omspatcher/<PATCH>/omspatcher_<timestamp>_deploy.log

[Apr 12, 2020 2:25:14 PM] Running apply prerequisite checks for sub-patch(es) "30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124" and Oracle Home "/refresh1/OEM134"...
[Apr 12, 2020 2:26:01 PM] [ Prerequisite Status: FAILED, Prerequisite output:
The details are:
Interim patch 30850543 requires prerequisite patch(es) [30850513] which are not present in the Oracle Home.
Apply prerequisite patch(es) [30850513] before applying interim patch 30850543.
Summary of Conflict Analysis:

There are no patches that can be applied now.
]
[Apr 12, 2020 2:26:01 PM] Prerequisite checks FAILED for sub-patch(es) "30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124".
[Apr 12, 2020 2:26:01 PM] OMSPatcher failed to validate some or all of patches binary prerequisite checks. Please refer log file(s) for more details.
[Apr 12, 2020 2:26:01 PM] Copying all logs to: <OMS_HOME>/cfgtoollogs/omspatcher/2020-04-12_14-21-56PM_SystemPatch_30895878_1
[Apr 12, 2020 2:26:01 PM] Patching summary:
-----------------
The following sub-patch(es) are not applicable:
oracle.sysman.top.oms:30851010,30850543,30851102,30850958,30851063,30851000,30851078,30851124

The following sub-patches are incompatible with components installed in the OMS system:
30971925

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.