My Oracle Support Banner

13.4: OMS Upgrade Fails During Upgrade Prerequisite Checks with Error: java.lang.UnsupportedClassVersionError: oracle/sysman/sdkImpl/core/ip/model/bipca/BIPCA : Unsupported major.minor version 52.0 (Doc ID 2687179.1)

Last updated on JULY 02, 2020

Applies to:

Enterprise Manager Base Platform - Version 13.4.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Upgrading OMS to 13.4 fails during the Upgrade Prerequisite checks with the error:

OMS_HOME/cfgtoollogs/cfgfw/CfmLogger<timestamp>.log

INFO: oracle.sysman.top.oms:The oldDomain name is <OMS_INSTANCE_HOME>/user_projects/domains/GCDomain
INFO: oracle.sysman.top.oms:The command run for OutOfBox is <OMS_HOME>/bin/configureBIP -noprompt -oldbip -oldbip_oraclehome <OLD_OMS_HOME> -oldbip_new_oraclehome <OMS_HOME> -olddomain <OLD_OMS_INSTANCE_HOME>/user_projects/domains/GCDomain -oldbipconfigfile <OMS_HOME>/.gcinstall_temp/bip_port.cfg
INFO: oracle.sysman.top.oms:Configuring BI Publisher to work with Enterprise Manager
INFO: oracle.sysman.top.oms:Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/sysman/sdkImpl/core/ip/model/bipca/BIPCA : Unsupported major.minor version 52.0
INFO: oracle.sysman.top.oms: at java.lang.ClassLoader.defineClass1(Native Method)
INFO: oracle.sysman.top.oms: at java.lang.ClassLoader.defineClass(ClassLoader.java:803)

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.