My Oracle Support Banner

EM 13c: In a Multi OMS Setup, Agents Failed to Secure With Error "The OMS is not set up for Enterprise Manager Security" (Doc ID 2689956.1)

Last updated on JULY 17, 2020

Applies to:

Enterprise Manager Base Platform - Version 13.3.0.0.0 and later
Information in this document applies to any platform.

Symptoms

EM 13c

3 OMS Servers behind SLB. Deployment of DB Plugin is completed on primary OMS Server and failed on the additional OMS Servers.

With this situation, executing 'emctl secure agent' command on any of the agents fails.

Following errors are reported in $AGENT_INST_HOME/sysman/log/secure.log

2020-07-12 03:36:55,733 [main] INFO agent.SecureAgentCmd openPage.1023 - Response body:OMS is unavailable

2020-07-12 03:36:55,734 [main] INFO agent.SecureAgentCmd getOMSSecurePort.967 - Non-numeric response obtained:OMS is unavailable

2020-07-12 03:36:55,735 [main] INFO agent.SecureAgentCmd getOMSSecurePort.969 - OMS Secure Port: -1
2020-07-12 03:36:55,735 [main] ERROR agent.SecureAgentCmd secureAgent.397 - The OMS is not set up for Enterprise Manager Security.
2020-07-12 03:36:55,739 [main] ERROR agent.SecureAgentCmd main.368 - Failed to secure the Agent:
java.lang.Exception: The OMS is not set up for Enterprise Manager Security.
  at oracle.sysman.emctl.secure.agent.SecureAgentCmd.secureAgent(SecureAgentCmd.java:398)

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.