My Oracle Support Banner

EM 13c: Cross Platform Migration using omsca recover Failing with Exported OS version is not compatible with local OS (Doc ID 2692259.1)

Last updated on SEPTEMBER 08, 2020

Applies to:

Enterprise Manager Base Platform - Version 13.3.0.0.0 and later
Information in this document applies to any platform.

Symptoms

 OMS Migration to cross platform using "omsca recover" failed with following error

<OMS_HOME>/bin>./omsca recover -as -ms -nostart -backup_file /tmp/DB_SW/opf_ADMIN_20200718_124323.bka -EM_BIP_PORT <port> -EM_BIP_HTTPS_PORT <port> -EM_BIP_OHS_PORT <port> -EM_BIP_OHS_HTTPS_PORT <port>

Oracle Enterprise Manager Cloud Control 13c Release 13.x.0.0.0
Copyright (c) 1996, 2020, Oracle. All rights reserved.

log4j:WARN No appenders could be found for logger (emctl.secure.oms.SecureOMSCmds).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Error while validating properties from backup file: Exported OS version is not compatible with local OS
java.lang.Exception: Exported OS version is not compatible with local OS
at oracle.sysman.omsca.framework.OMSCARecoveryConfig.init(OMSCARecoveryConfig.java:222)
at oracle.sysman.omsca.framework.OMSConfigAssistantDriver.main(OMSConfigAssistantDriver.java:268)
<OMS_HOME>/bin>

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.