My Oracle Support Banner

13.3 EM : Analyzing PSU Failed With "apply failed: oracle/glcm/opatch/common/api/Utility" (Doc ID 2738611.1)

Last updated on DECEMBER 21, 2020

Applies to:

Enterprise Manager Base Platform - Version 13.3.0.0.0 and later
Information in this document applies to any platform.

Symptoms

13.3 EM , Analyze oms #31899771 psu patch failed with below error

$ORACLE_HOME/OMSPatcher/omspatcher apply -analyze

OMSPatcher Automation Tool
Copyright (c) 2017, Oracle Corporation. All rights reserved.

OMSPatcher version : 13.8.0.0.3
OUI version : 13.8.0.0.0
Running from : /<OMS_MW_HOME>
Log file location : /<OMS_MW_HOME>/cfgtoollogs/omspatcher/opatch<TIME_STAMP>log

OMSPatcher log file: /<OMS_MW_HOME>/cfgtoollogs/omspatcher/31899771/omspatcher_<TIME_STAMP>_analyze.log

Please enter OMS weblogic admin server URL(t3s://<HOSTNAME>:<PORT>):>
Please enter OMS weblogic admin server username(weblogic):>
Please enter OMS weblogic admin server password:>

Configuration Validation: Success
Running apply prerequisite checks for sub-patch(es) "31899771" and Oracle Home "/<OMS_MW_HOME>"...
Prerequisite checks FAILED for sub-patch(es) "31899771".

Complete Summary
================

All log file names referenced below can be accessed from the directory "/<OMS_MW_HOME>/cfgtoollogs/omspatcher/<TIME_STAMP>_SystemPatch_31899771_1"
Prerequisites analysis summary:
-------------------------------

The following sub-patch(es) are not applicable:

Featureset Sub-patches Log file
---------- ----------- --------
oracle.sysman.top.oms 31899771 31899771_opatch2020-12-16_09-51-43AM_1.log

[ Error during Run sub-patch(es) binary prerequisite checks Phase]. Detail: Some of the prerequisite checks to apply or rollback the patch(es) have failed.
OMSPatcher failed: Some of the prerequisite checks to apply or rollback the patch(es) have failed.
Log file location: /<OMS_MW_HOME>/cfgtoollogs/omspatcher/31899771/omspatcher_<TIME_STAMP>_analyze.log

Recommended actions: Please refer log file(s) for more details on the errors. Please contact Oracle Support.

OMSPatcher failed with error code 238

.
$<OMS_MW_HOME>/cfgtoollogs/omspatcher/31899771/omspatcher_<TIME_STAMP>_analyze.log has below errors.

Dec 16, 2020 9:52:04 AM] Running apply prerequisite checks for sub-patch(es) "31899771" and Oracle Home "/<OMS_MW_HOME>"...
[Dec 16, 2020 9:52:28 AM] [ Prerequisite Status: FAILED, Prerequisite output:
The details are:
ApplySession failed but Oracle Home has not been modified.ApplySession::apply failed: oracle/glcm/opatch/common/api/Utility]
[Dec 16, 2020 9:52:28 AM] Prerequisite checks FAILED for sub-patch(es) "31899771".
[Dec 16, 2020 9:52:28 AM] OMSPatcher failed to validate some or all of patches binary prerequisite checks. Please refer log file(s) for more details.
[Dec 16, 2020 9:52:28 AM] Copying all logs to: /<OMS_MW_HOME>/cfgtoollogs/omspatcher/<TIME_STAMP>_SystemPatch_31899771_1
[Dec 16, 2020 9:52:28 AM] Prerequisites analysis summary:
-------------------------------
The following sub-patch(es) are not applicable:

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.