My Oracle Support Banner

EM 13c: "orapki wallet display" Command Failed With Error "java.lang.UnsupportedClassVersionError: oracle/security/pki/textui/OraclePKITextUI : Unsupported major.minor version 51.0" (Doc ID 2740798.1)

Last updated on JANUARY 17, 2023

Applies to:

Enterprise Manager Base Platform - Version 13.1.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Enterprise manager cloud control 13.4
Execution of "orapki wallet display" Command failed with below error:

[oracle@oms bin]$ ./orapki wallet display -wallet <WALLET LOCATION>
Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/security/pki/textui/OraclePKITextUI : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: oracle.security.pki.textui.OraclePKITextUI. Program will exit.

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.