My Oracle Support Banner

OEM13c: Fleet UPDATE_GI Fails In Switch_Cluster Step With Error "ORA-06512: at "SYS.DBMS_AQADM_SYS", line 15446" (Doc ID 2749134.1)

Last updated on MARCH 10, 2021

Applies to:

Enterprise Manager for Oracle Database - Version 13.4.1.0.0 and later
Information in this document applies to any platform.

Symptoms

In Cloud Control Enterprise Manager using Fleet, When running the UPDATE_GI command in RAC cluster environment, the process fails in switch cluster step with the following error.

Command Snippet:

$ emcli db_software_maintenance -performOperation -name="Update GI" -purpose=UPDATE_GI -target_type=cluster -target_list="<TARGET_NAME>" -normal_credential="ORACLE:SYSMAN" -privilege_credential="ROOT:SYSMAN"

Job Steps Log : Switch Cluster Step:

Executing file rootcrs.pl
Destination Clusterware Home version is: 19.0.0.0.0
2021-02-02 13:18:40: Executing /u01/app/19.8.0.0/grid/crs/install/rootcrs.sh -postpatch -dstcrshome /u01/app/19.8.0.0/grid
2021-02-02 13:18:40: Executing cmd: /u01/app/19.8.0.0/grid/crs/install/rootcrs.sh -postpatch -dstcrshome /u01/app/19.8.0.0/grid
Using configuration parameter file: /u01/app/19.8.0.0/grid/crs/install/crsconfig_params
The log of current session can be found at:
/u01/app/oracle/crsdata/crsconfig/crs_postpatch_-02_01-18-40PM.log
Oracle Clusterware active version on the cluster is [19.0.0.0.0]. The cluster upgrade state is [ROLLING PATCH]. The cluster active patch level is [3330312929].
2021/02/02 13:20:05 CLSRSC-329: Replacing Clusterware entries in file 'oracle-ohasd.service'
Oracle Clusterware active version on the cluster is [19.0.0.0.0]. The cluster upgrade state is [NORMAL]. The cluster active patch level is [519062584].
SQL Patching tool version 19.8.0.0.0 Production on Tue Feb 2 13:24:11 2021
Copyright (c) 2012, 2020, Oracle. All rights reserved.
Patch 31281355 apply (pddb: WITH ERRORS
logfile: /u01/app/oracle/cfgtoollogs/sqlpatch/31281355/23688465/31281355_apply_b02_13_26_26.log (errors)
-> Error at line 45: script rdbms/admin/bug_29784106_prepatch.sql
- ORA-00600: internal error code, arguments: [pfri.c#103: bad lu type], [22], [],
- [], [], [], [], [], [], [], [], []
- ORA-06512: at "SYS.DBMS_AQADM_SYS", line 15446
- ORA-06512: at "SYS.DBMS_AQADM_SYSCALLS", line 778
- ORA-06512: at "SYS.DBMS_AQADM", line 769
- ORA-06512: at line 5
- ORA-06512: at line 5

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.