My Oracle Support Banner

13.4: Install or Upgrading Agent to 13.4 Fails With Error: /lib64/libc.so.6: version `GLIBC_2.10' not found (Doc ID 2757234.1)

Last updated on MARCH 02, 2021

Applies to:

Enterprise Manager Base Platform - Version 13.4.0.0.0 and later
Linux x86-64

Symptoms

Installing/Upgrading agent to 13.4 fails during the "Deploying Agent image" step with the error:

Agent Software install completed
Creating symlink <AGENT_HOME>/oracle_common/jdk/bin <AGENT_HOME>/jdk/bin
Executing command to check/apply patches if exist in agenthome.....
<AGENT_HOME>/perl/bin/perl <AGENT_HOME>/install/oneoffs/apply_NewOneoffs.pl <AGENT_HOME> true
<AGENT_HOME>/perl/bin/perl: /lib64/libc.so.6: version 'GLIBC_2.10' not found (required by <AGENT_HOME>/perl/bin/perl)
<AGENT_HOME>/perl/bin/perl: /lib64/libc.so.6: version 'GLIBC_2.6' not found (required by <AGENT_HOME>/perl/bin/perl)
<AGENT_HOME>/perl/bin/perl: /lib64/libc.so.6: version 'GLIBC_2.7' not found (required by <AGENT_HOME>/perl/bin/perl)
<AGENT_HOME>/perl/bin/perl: /lib64/libc.so.6: version 'GLIBC_2.9' not found (required by <AGENT_HOME>/perl/bin/perl)
Oneoff patch application failed

Passing the argument -ignorePrereqs in the additional parameters did not help.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.