Problem: MS SQL Server target Metrics not collected and Reports empty: OS user privilege issue (Doc ID 367814.1)

Last updated on NOVEMBER 02, 2015

Applies to:

Enterprise Manager for Miscellaneous Plug-ins - Version 10.2.0.1 to 11.1.0.1 [Release 10.2 to 11.1]
Information in this document applies to any platform.
Checked for relevance on 06-Aug-2010
Checked for relevance on 11-Feb-2013


Symptoms

Oracle Enterprise Manager Grid Console 10.2.0.1.0 on
Red Hat Enterprise Linux AS release 3 (Taroon Update 6) 2.4.21 37.ELsmp (32-bit)
Oracle Management Agent 10.2.0.1.0 and Microsoft SQL Server installed on the same Windows 2003 node (Local Monitoring)

The target MS SQL Server was successfully discovered and shows a status UP in Grid Control
All the metrics retrieved using the WMI fetchlet are not collected.
Practically all reports are empty.

MS Active Directory is in use.
MS SQL Server was installed with domain\user1 which belongs to the local Administrators group
The Management Agent was installed with domain\user1 which belongs to the local Administrators group
The Management Agent windows service is started as local SYSTEM account.
The WMI support setup.exe was launched from the SQL Server Installation CD, /x86/other/wmi with domain\user2

Diagnostics run with wbemtest and CIM Studio show that WMI works successfully when connected with the user domain\user2.


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms