Discoverer 11g In SSL Mode Redirects To HTTP And Displays Browser Security Warning Followed By Discoverer Connection Page With Missing Images (Doc ID 1321210.1)

Last updated on DECEMBER 09, 2016

Applies to:

Oracle Discoverer - Version 11.1.1.4.0 to 11.1.1.7.0 [Release 11g]
Information in this document applies to any platform.

Symptoms

Installed FMW 11g, including Forms, Reports and Discoverer.
Trying to set up SSL so that web cache is bypassed and requests are routed via HTTPS through the HTTP server instead of web cache.

When using default port for Oracle Discoverer Viewer, via http, all is working fine and pages display and behave as expected.

When using https via port 8890, a Mozilla Firefox security warning appears:

"You have requested an encrypted page that contains some unencrypted information.
Information that you see or enter on this page could easily be ready by a third party."

[OK is only option on dialog window]



Once OK is selected, the page displays, but the images on the connections page are missing.

The  /oracle/fmw/user_projects/domains/ClassicDomain/servers /WLS_DISCO/log/WLS_DISCO.log includes messages stating:

  "... https is not fully deployed..."


You may also see missing images and a slightly different message in the WLS_DISCO.log file.  For example:

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms