Sporadic / Occasional Authentication errors accessing OBIEE 11g (Doc ID 1472209.1)

Last updated on MARCH 08, 2017

Applies to:

Business Intelligence Suite Enterprise Edition - Version 11.1.1.5.0 [1308] and later
Information in this document applies to any platform.
***Checked for relevance on 17-Jan-2014***

Symptoms

Having sporadic occasional authentication errors when accessing OBIEE 11g.

- Endusers are often not able to run OBIEE contents in several time slots a week.

- Unavailability doesn't run more than 5 to 10 minutes but it may happens more than once a day

- Users who are already logged in cannot display or use presentation server items ( report, dashboard or navigate through the catalog ). They get this:

Error Codes: GDU6UYHS:OPR4ONWY:U9IM8TAC:OI2DL65P
Location:saw.security.odbcuserpopulatonimpl.serachidentities,saw.security.userpopulationmanagerimpl.getaccountdetailsbyid,saw.subsystem.portal, saw.httpserver.processrequest, saw.rpc.server.responder,saw.rpc.server, saw.rpc.server.handleConnection,saw.rpc.server.dispatch,saw.threadpool,saw.threadpool,saw.threads
Odbc driver returned an error(SQLExecDirectW).
State: HY000.  Code: 10058.  [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred.
[nQSError: 43113] Message returned from OBIS.
Error Message From BI Security Service: javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: DomainDnsZones.tp.tpnet.intra:389 [Root exception is java.net.ConnectException: Connection timed out: connect]] (HY000)
SQL Issued: {call NQSSearchIdentities('BOTH','GUID=ADAdministrator')}

 
- Users who were not connected can not manage to pass the authentication, they get this error:

Error
Error retrieving user/group data from Oracle BI Server's User Population API. Odbc driver returned an error (SQLExecDirectW).  State: HY000. Code: 10058 [NQODBC]
[SQL_STATE:HY000] [nQSError: 10058] A general error has occurred.   [nQSError: 43113] Message returned from OBIS.  Error message from BI Security Service:
javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: DomainDnsZones.tp.tpnet.intra:389 [Root exception is java.net.ConnectException; Connection timed out:connect]] (HY000) SQL issued: {call NQSSearchIdentities('BOTH'.'GUID=HRRetention')}
OK


- All the Active Directory users are affected.

- The issue runs usually for 5 to 10 mins. Authentication works well after that without having to restart any of the services.  

- While it is occurring Console or EM is still available, ping is ok to the Active Directory host


Additional Information:

- using ldap browser from a laptop or from the server, managed to get some results during the same time the issue is occurring, with same parameters.

- nqserver.log displays a quantity of messages like the following for those unavailable time slots.

[2012-05-16T12:46:16.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 00i7f2ZnHLnFw00Fzzw0w000019K000000] [tid: 1220] Error Message From BI Security Service: javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: DomainDnsZones.tp.tpnet.intra:389 [Root exception is java.net.ConnectException: Connection timed out: connect]]

[2012-05-29T10:52:08.000+00:00]  [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 00i7w3cZ8bSFw0zsBT07rz5gT^U3j3IwG0001p^000Ysy] [tid: fd8]  [nQSError: 17010] SQL statement preparation failed. [[[nQSError: 17001] Oracle Error code: 942, message: ORA-00942: table or view does not exist  at OCI call OCIStmtExecute. [nQSError: 13011] Query for Initialization Block 'Enablon_Translation' has failed.

[2012-05-29T11:05:14.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: aa95eb86b404fed1:43b226b0:1377a647997:-8000-000000000002d899] [tid: 2ef4] Error Message From BI Security Service:
javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: DomainDnsZones.tp.tpnet.intra:389 [Root exception is java.net.ConnectException: Connection timed out: connect]] [[[nQSError: 43113] Message returned from OBIS.]]

- There appears to be no link between times when the cpu is at 100% & when this issue occurs.

Config is:
- OS : Windows Server 2008 R2
- RAM : 8 Gigs

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms