OBIEE 11g Analysis Runs in OBIEE Presentation Server; Gives Blank Screen And Fails To Generate XML When Run in BI Publisher 11g (Doc ID 1587154.1)

Last updated on JUNE 07, 2016

Applies to:

Oracle Exalytics Software - Version 1.0.0.2.0 to 1.0.0.3.0 [Release 1.0]
Business Intelligence Suite Enterprise Edition - Version 11.1.1.6.4 to 11.1.1.7.1 [Release 11g]
Information in this document applies to any platform.

Symptoms

Using Oracle Business Intelligence Enterprise Edition (OBIEE) 11.1.1.6.4 and 11.1.1.7.1 with OBI Publisher (BIP) on an Oracle Exalytics server.
Some of the OBIEE Analyses are run in OBIEE Presentation server and always return expected results.

If any of these analyses are used as a data source in a BIP report, and "Get XML output" is clicked, no output is ever created and the screen goes blank.

If the "get data engine log" button is clicked, no log file ever displays.

The OBIEE presentation server log shows that the query was executed and that rows were returned, but then activity seems to stop and hang when running ExecuteXMLQuery:

<SawDataSet> <getSAWReportXMLData> SawDataSet: execute webservice call.
  <AbstractSawXmlViewService> <getXMLQueryResults> Start Invoking
  ExecuteXMLQuery..
  <AbstractSawXmlViewService> <getXMLQueryResults> Before Query Results...


This problem is limited to those BIP reports that use an OBIEE Analysis (which is stored in the catalog), as a data source.  If SQL datasets, or other data sources, are used; the BI Publisher reports consistently work as expected.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms