Unable To Connect To Dac In Command Line Using AutomationUtils.sh Utility on AIX (Doc ID 1936355.1)

Last updated on MARCH 08, 2017

Applies to:

Business Intelligence Applications Consumer - Version 11.1.1.6.0 and later
Information in this document applies to any platform.

Symptoms

Running the 'automationutils' Command Line for DAC 11g on an AIX Server gives the following 'authentication' error :-

OS detected: AIX
Sep 5, 2014 3:43:28 PM com.siebel.etl.functional.AutomationUtils main
INFO: Arguments received:
  "automationutils.properties"
  "EXPORTCATEGORY"
  "/busapps/dchb/gbl0/dac/backup/export"
  "logical"
  "false"
  "false"
Sep 5, 2014 3:43:28 PM com.siebel.etl.etlmanager.DerivedConstants getDacDomainHome
INFO: The DAC_DOMAIN_HOME set to /busapps/dchb/gbl0/dac
Sep 5, 2014 3:43:28 PM com.siebel.etl.etlmanager.DerivedConstants getDacConfigLocation
INFO: The DAC_CONFIG_LOCATION value hasn't been found, the USERDIR value was used instead
Sep 5, 2014 3:43:28 PM com.siebel.etl.etlmanager.DerivedConstants getDacConfigLocation
INFO: The DAC_CONFIG_LOCATION set to /busapps/dchb/gbl0/dac
Sep 5, 2014 3:43:28 PM com.siebel.etl.etlmanager.DerivedConstants getOracleDacHome
INFO: The BI_ORACLE_HOME value hasn't been found, the USERDIR value was used instead
Sep 5, 2014 3:43:28 PM com.siebel.etl.etlmanager.DerivedConstants getOracleDacHome
INFO: The ORACLEDIR set to /busapps/dchb/gbl0/dac
Sep 5, 2014 3:43:28 PM com.siebel.etl.functional.AutomationUtils connectInServerMode
INFO: reading connection information...
Sep 5, 2014 3:43:28 PM com.siebel.etl.bootup.ApplicationManager
INFO: Application booting up...
Sep 5, 2014 3:43:29 PM oracle.security.jps.internal.common.util.XmlSchemaValidationUtil$StrictErrorHandler warning
WARNING: Failed to validate the xml content. SchemaLocation: schemaLocation value = 'http://xmlns.oracle.com/oracleas/schema/11/jps-config-11_1.xsd' must have even number of URI's. Location: line 2 column 272.
Sep 5, 2014 3:43:31 PM com.siebel.etl.functional.AutomationUtils connectInServerMode
INFO: connecting...

Sep 5, 2014 3:43:32 PM com.siebel.analytics.etl.client.data.model.OldXMLProcessor init
INFO:

 ********

Table Name is: W_ETL_APP

 ********


Sep 5, 2014 3:43:32 PM com.siebel.analytics.etl.client.data.objectcomponents.ModelStruct setQuery
INFO: SELECT
  APP.NAME
  ,APP.ABSTRACT_FLG
  ,APP.OOB_FLG
  ,APP.PARENT_APP_WID
  ,APP.COMMENTS
  ,APP.ROW_WID
  ,APP.LAST_UPD
FROM W_ETL_APP APP
WHERE
  (APP.INACTIVE_FLG='N')
ORDER BY
  APP.NAME ASC
Sep 5, 2014 3:43:32 PM com.siebel.analytics.etl.client.data.model.ConnectionHandler getConnection
INFO: Getting connection for: Model structure for W_ETL_APP (APP) (currently 0)
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ResultSetParser logMinutesSeconds
INFO: Query took 0 minutes, 0 seconds
Sep 5, 2014 3:43:33 PM com.siebel.etl.engine.core.DateTimeHandler getCurrentDBTimestamp
INFO: Closing result set after executing SELECT SYSDATE AS CURRENT_TS FROM DUAL against null
Sep 5, 2014 3:43:33 PM com.siebel.etl.bootup.ApplicationManager getTSDifferenceBetweenClientAndRepo
INFO: Time delta between local and repository: -138
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ConnectionHandler cleanUp
INFO: Returning connection for: Model structure for W_ETL_APP (APP) (currently 1)
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ResultSetParser logMinutesSeconds
INFO: Populating DACObjects took 0 minutes, 0 seconds
Sep 5, 2014 3:43:33 PM com.siebel.etl.functional.AutomationUtils connectInServerMode
INFO: Connection established.
Sep 5, 2014 3:43:33 PM com.siebel.etl.functional.AutomationUtils login
INFO: tring to authenticate..
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.objectcomponents.ModelStruct setQuery
INFO: SELECT
  A_W_ETL_USER.ROW_WID
  ,A_W_ETL_USER.LAST_UPD
  ,A_W_ETL_USER.INACTIVE_FLG
  ,A_W_ETL_USER.NAME
  ,A_W_ETL_USER.PASSWORD
  ,A_W_ETL_USER.ROLES
  ,A_W_ETL_USER.VERSION_ID
  ,A_W_ETL_USER.COMMENTS
FROM W_ETL_USER A_W_ETL_USER
WHERE
  (upper(INACTIVE_FLG)=upper(?))
  AND (upper(NAME)=upper(?))
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ConnectionHandler getConnection
INFO: Getting connection for: Model structure for W_ETL_USER (A_W_ETL_USER) (currently 0)
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ResultSetParser logMinutesSeconds
INFO: Query took 0 minutes, 0 seconds
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ConnectionHandler cleanUp
INFO: Returning connection for: Model structure for W_ETL_USER (A_W_ETL_USER) (currently 1)
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.client.data.model.ResultSetParser logMinutesSeconds
INFO: Populating DACObjects took 0 minutes, 0 seconds
Sep 5, 2014 3:43:33 PM com.siebel.analytics.etl.usermodel.TCPUserManager setCurrentUser
INFO: Authentication failed. Cause: username or password is incorrect
Sep 5, 2014 3:43:33 PM com.siebel.etl.functional.AutomationUtils login
SEVERE: Authentication failed
Sep 5, 2014 3:43:33 PM com.siebel.etl.functional.AutomationUtils main
INFO: Failure!

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms