Getting Error " Failed To Load Adapter Jar Lib From Database While Configuring Mapviewer" In OBIEE 11g (Doc ID 1943148.1)

Last updated on NOVEMBER 14, 2014

Applies to:

Business Intelligence Server Enterprise Edition - Version 11.1.1.7.140715 and later
Information in this document applies to any platform.

Symptoms

MapViewer is working fine in your Dev environment but not in Stage environment.

  1. Dev is a standalone environment whereas stage is a clustered environment.
  2. One schema "MVDEMO2" is getting used in dev environment and the details have been used in the mapviewer xml located at
      /opt2/OBI/Oracle_BI1/bifoundation/jee/mapviewer.ear/web.war/WEB-INF/conf/mapViewerConfig.xml
  3. The full schema has been imported to your Stage database.
  4. Post movement of the mvdemo2 schema from Dev to Stage the required information has been used on the Mapviewer xml located in stage at
      /opt2/OBI/user_projects/domains/bifoundation_domain/servers/bi_server1/stage/mapviewer/mapviewer.ear/web.war/WEB-INF/conf/mapViewerConfig.xml
  5. Given the below tag in instance config.xml
       1000
  6. After modifying the Mapviewer xml we have restated the Mapviewer in Stage environment and able to see the datasources but
  7. In manage Tile layers nothing is appearing
  8. When we are going to Answers - Manage map data no layers are appearing.
  9. PFA logs where i am seeing that below are the Example of errors which are appearing :
    SEVERE: Failed to load adapter jar lib from database
    SEVERE: Error in loading map tile layer config from database!(MVDEMO,WORLD_MAP)
    SEVERE: MAPVIEWER-06035: Base map does not exist.(MVDEMO,WORLD_MAP)
  10. PFA logs and mapviewer xml and screenshot of the manage map data screen.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms