OBIA Upgrade to 7.9.6.4 - Equalizing the Oracle BI Repositories errors out

(Doc ID 1998891.1)

Last updated on JANUARY 31, 2017

Applies to:

Business Intelligence Applications Consumer - Version 7.9.6.4 and later
Information in this document applies to any platform.

Symptoms

As part of an upgrade, OBIEE 11.1.1.7.15 was installed and then BI Apps 7.9.6.4 and now following the Oracle documentation:-

Oracle® Business Intelligence Applications Upgrade Guide for Informatica PowerCenter Users
Release 7.9.6.4
Part Number E35270-01

6.14 Merging Oracle BI Applications Version 7.9.6.4 Repository With Customer Repository

Getting an error when performing the following:

E:\OBIEE11g\Oracle_BI1\bifoundation\server\bin>obieerpdmigrateutil.exe -P Admin123 -R C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd -O C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7963.rpd -F upgrade

[nQSError: 36015] Please run the upgrade utility obieerpdmigrateutil to upgrade the repository C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd.


If the following command is run:

E:\OBIEE11g\Oracle_BI1\bifoundation\server\bin>equalizerpds.exe -B SADMIN -C C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd -D Administrator -E SADMIN -F C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\OracleBIAnalyticsApps.rpd -O C:\Users\biadmin\Oracle\OracleBIUpgrade\AfterEqualize\OracleBIAnalyticsApps.rpd -J rename7963-7964.map

The following error is displayed:

 

The following repository cannot be opened: C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd
[nQSError: 36015] Please run the upgrade utility obieerpdmigrateutil to upgrade the repository C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd.


Then the following command:


E:\OBIEE11g\Oracle_BI1\bifoundation\server\bin>obieerpdmigrateutil.exe -P Admin123 -R C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd -O C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7963.rpd -F upgrade

 

[nQSError: 36015] Please run the upgrade utility obieerpdmigrateutil to upgrade the repository C:\Users\biadmin\Oracle\OracleBIUpgrade\Original\EnterpriseBusinessAnalytics_7962.rpd.


The "EnterpriseBusinessAnalytics_7962.rpd" was copied from $ORACLE_BI_HOME\biapps\upgrade. This is the closest version you see. Although there is "EnterpriseBusinessAnalytics_794.rpd", but this doesn't appear to be the correct version, you have also copied the map file, "rename7963-7964.map" from $ORACLE_BI_HOME\biapps\upgrade.

You are not using any Admin tool to issue the commands. Commands are issued from Command prompt.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms