OBIEE 11g Patch Fails with Error: "CheckPatchApplicableOnCurrentPlatform" (Doc ID 2054102.1)

Last updated on SEPTEMBER 17, 2015

Applies to:

Business Intelligence Suite Enterprise Edition - Version 11.1.1.7.0 and later
Information in this document applies to any platform.

Symptoms

User applies a patch and the sub-patch is failing with the below error:

Prerequisite check "CheckPatchApplicableOnCurrentPlatform" failed.

 

The oPatch log is below:


opatch apply
Oracle Interim Patch Installer version 11.1.0.9.9
Copyright (c) 2012, Oracle Corporation.  All rights reserved.


Oracle Home       : /u01/app/Oracle/Middleware/Oracle_BI1
Central Inventory : /u01/app/oraInventory
  from           : /u01/app/Oracle/Middleware/Oracle_BI1/oraInst.loc
OPatch version    : 11.1.0.9.9
OUI version       : 11.1.0.9.0
Log file location : /u01/app/Oracle/Middleware/Oracle_BI1/cfgtoollogs/opatch/18657616_Sep_04_2015_12_49_51/apply2015-09-04_12-49-51PM_1.log


OPatch detects the Middleware Home as "/u01/app/Oracle/Middleware"

Applying interim patch '18657616' to OH '/u01/app/Oracle/Middleware/Oracle_BI1'
Verifying environment and performing prerequisite checks...
Prerequisite check "CheckPatchApplicableOnCurrentPlatform" failed.
The details are:
Patch ( 18657616 ) is not applicable on current platform.
Platform ID needed is : 226
Platform IDs supported by patch are: 46
Log file location: /u01/app/Oracle/Middleware/Oracle_BI1/cfgtoollogs/opatch/18657616_Sep_04_2015_12_49_51/apply2015-09-04_12-49-51PM_1.log

Recommended actions: This patch requires some components to be installed in the home. Either the Oracle Home doesn't have the components or this patch is not suitable for this Oracle Home.

OPatch failed with error code 39

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms