After Performing An In-Place Upgrade Of EPM Shared Services Is Not Working (Doc ID 2093455.1)

Last updated on JUNE 01, 2017

Applies to:

Hyperion Planning - Version 11.1.2.4.000 and later
Information in this document applies to any platform.

Symptoms

After performing an in place upgrade of EPM The shared services page does not come up. The error log indicates this:

<Dec 18, 2015 11:45:12 AM CST> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application 'SHAREDSERVICES [Version=11.1.2.0]'.
weblogic.application.ModuleException: [HTTP:101216]Servlet: "WorkflowEngine" failed to preload on startup in Web application: "interop".
javax.servlet.ServletException: DSF initialization error ORA-00904: "PROCESSNAME": invalid identifier

 

If you compare the failed upgrade to a new install you will find some or all of the following tables missing

ANNOT_CONTEXTS14
ANNOT_ELEMENT_GROUP114
ANNOT_ELEMENT_GROUP214
ANNOT_ELEMENT_GROUP314
ANNOT_ELEMENT_GROUPS14
ANNOT_ELEMENT_SETS14
ANNOT_ELEMENT_VALUES14
ANNOT_ELEMENTS14
CONFIG_HISTORY
CSS_GROUP_CACHE_DELTA    (see related KM 2061471.1)
EPM_REGISTRY_LOCK
FR_SCHEDULER_DATA14
FR_USERPREFS
REPOSITORY_OBJECT_ACLS
REPOSITORY_OBJECT_PROP_INDEX
REPOSITORY_OBJECT_PROPERTIES
REPOSITORY_OBJECTS
V8_KPS_ACTION_QUEUE14
V8_METATYPE14
V8_MON_POLL14
V8_SRCH_CONT_EVENT14

 

Changes

During the first run of the Foundation services database config it failed, perhaps the schema connection user have full rights to modify the schema during the upgrade (drop and create tables and indexes) or there was some other problem.  Re-running it appears to succeeded.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms