OBIEE 11g: Redirection to Analytics Fails after SSO Authentication via SAML (Doc ID 2128846.1)

Last updated on FEBRUARY 10, 2017

Applies to:

Business Intelligence Server Enterprise Edition - Version 11.1.1.9.0 and later
Information in this document applies to any platform.

Symptoms

On OBIEE 11.1.1.9.x with WLS 10.3.6

Single Sign On (SSO) is enabled for OBIEE using SAML, and users are able to successfully login to OBIEE, however the SSO model is IdP-initiated; that is:-

1. The user navigates to the IdP URL and is redirected to the SSO Login Page where the user enters his credentials
2. After successful authentication at the IdP, the user is redirected back to OBIEE (/analytics)

As per the OBIEE Product Management team, only the SP-initiated SSO model is certified and supported for OBIEE; that is:-

1. The user navigates to the OBIEE URL (/analytics) and is redirected to the SSO Login Page where the user enters his credentials
2. After successful authentication at the IdP, the user is redirected back to OBIEE (/analytics)

The configuration is changed to the SP-initiated SSO model. 

Now, after the user is authenticated at the IdP (step #2), the redirection back to OBIEE (/analytics) fails and the browser "spins" continuously until a time-out finally occurs.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms