Show Data As Percent Of Column Gives Wrong Value After Applying Custom Format Masks (Doc ID 2135309.1)

Last updated on FEBRUARY 10, 2017

Applies to:

Business Intelligence Suite Enterprise Edition - Version 11.1.1.9.160119 and later
Information in this document applies to any platform.

Symptoms

OBIEE environment has been upgraded to 11.1.1.9.160119 from 11.1.1.7.0. Show Data As > Percent of Column gives wrong value after applying Custom Format Masks. This was working fine in OBIEE 11.1.1.7.0.

Expect Show Data As > Percent of Column after applying Custom Format Masks to work in OBIEE 11.1.1.9.160119.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1) Create a report with an Attribute column and a measure column
2) Create a pivot table view at the compound layout
3) Duplicate measure column and set the below mentioned property for the duplicate layer
Show Data As --> Percent of --> Column

4) Verify that report output is showing the % value.
5) Navigate to the criteria tab and set the column property for the measure column as mentioned below.

Data Format --> Override Default Data format --> Treat Numbers as Custom --> Give Custom numeric format as #,##0;-#,##0;0
 
Note : The custom numeric format is given to display 0 in place of null in pivot table.
 
6) Check the report output. Verify that % value is not displayed correctly.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms