Disclosure Management Deployment Failed To Start After Upgrading JRockit And JDK To 1.7

(Doc ID 2396246.1)

Last updated on MAY 14, 2018

Applies to:

Hyperion Disclosure Management - Version 11.1.2.4.000 and later
Information in this document applies to any platform.

Symptoms

DiscMan Web App fails to start after updating EPM JVM to 1.7.  Web App log contains messages similar to:

    ####<Apr 23, 2018 1:08:26 AM MST> <Error> <Deployer> <hqdltexavm01> <DisclosureManagement0> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <>   <0000MBlYwyN7e505Vzk3yc1QrPHg000001> <1524470906320> <BEA-149231> <Unable to set the activation state to true for the application 'DISCLOSUREMANAGEMENT [Version=11.1.2.0]'.
    weblogic.application.ModuleException:
    at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1531)
    at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:488)
    ...................
    at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
    at weblogic.work.ExecuteThread.execute(ExecuteThread.java:263)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)
    Caused By: java.lang.IllegalArgumentException: error the @annotation pointcut expression is only supported at Java 5 compliance level or above
    at org.aspectj.weaver.tools.PointcutParser.parsePointcutExpression(PointcutParser.java:317)

Changes

 Upgrade EPM JVM to Java Version 1.7

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms