My Oracle Support Banner

OBIEE 12c: Upgrade From 12.2.1.0 To 12.2.1.3 Fails With Error UPGAST-00214: Unable To Connect To Database As The Schema User <PreFix>_BIPLATFORM (Doc ID 2400420.1)

Last updated on JUNE 11, 2018

Applies to:

Business Intelligence Server Enterprise Edition - Version 12.2.1.0.0 to 12.2.1.3.0 [Release 12g]
Information in this document applies to any platform.

Symptoms

To upgrade from obiee 12.2.1.1 to 12.1.1.3  referring upgrade guide as below

7 Upgrading Oracle Business Intelligence from a Previous 12c Release

https://docs.oracle.com/en/middleware/lifecycle/12.2.1.3/obiup/upgrading-oracle-business-intelligence-previous-12c-release.html#GUID-93B3A0DC-7546-4ABB-946E-593B3AAE444D

 at step : Upgrading Product Schemas - Starting the Upgrade Assistant

While checking server readiness with readiness parameter , it fails with below error - 

 [Framework] [NOTIFICATION] [] [upgrade.Framework] [tid: 12] [ecid: 033cb5a1-a351-4ef0-b488-c888133d6d8e-00000002,0] The auto-datasource mode is ignoring data source biplatform_datasource because the connection failed with the error: UPGAST-00214: Unable to connect to database as the schema user "<PreFix>_BIPLATFORM".
[Framework] [NOTIFICATION] [] [upgrade.Framework] [tid: 12] [ecid: 033cb5a1-a351-4ef0-b488-c888133d6d8e-00000002,0] Database connect string for user UAT_IAU_APPEND: jdbc:oracle:thin:@//<DB_SERVERS>:<DB_PORT>/<SERVICE_NAME>
[Framework] [ERROR] [] [upgrade.Framework] [tid: 12] [ecid: 033cb5a1-a351-4ef0-b488-c888133d6d8e-00000002,0] SQLState: 99999, Error Code: 17,067, Message: Invalid Oracle URL specified

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.