My Oracle Support Banner

UnsupportedClassVersionError: Odi11gInterafceToFile : Unsupported Major.minor Version 52.0 (Doc ID 2850233.1)

Last updated on FEBRUARY 25, 2022

Applies to:

Business Intelligence Applications Consumer - Version 11.1.1.10.2 and later
Information in this document applies to any platform.

Goal

While using Migration Utility for migrating OBIA-ODI 11g version customizations from prior OBIA 11.1.1.10.x releases to OBIA 11.1.1.10.3 release getting below error :

 

Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/biapps/odi/mapping/upgrade/Odi11gInterafceToFile : Unsupported major.minor version 52.0
  at java.lang.ClassLoader.defineClass1(Native Method)
  at java.lang.ClassLoader.defineClass(ClassLoader.java:808)
  at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
 

 

Refer : OBIA 12c: ODI Customizations Migration Utility

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.