Package BISM_CALC_FILTER is Invalid After Installing the BI Beans or D4O Catalog into a 10.2.0.4 RDBMS (Doc ID 737101.1)

Last updated on MAY 12, 2017

Applies to:

Oracle OLAP - Version: 10.2.0.4 and later   [Release: 10.2 and later ]
Oracle BI Beans - Version: 10.1.2.2 and later    [Release: 10gR1 and later]
Information in this document applies to any platform.

Symptoms

When trying to install the 10.1.2.2 BI Beans Catalog into an RDBMS version 10.2.0.4 the following error comes up at the end of the Installation:

C:\oracle\JDeveloper\bibeans\bin>bi_installcatalog bibcat bibcat -h olapserv3 -p o 1521 -sid o10gr2 -j thin
This procedure will upgrade your BI Beans Catalog schema.  All existing catalog
objects will be lost.  Use the Import/Export utilities if you would like to pres
erve your data. Press CTRL-C to abort.
Press any key to continue . . .
bi_installcatalog: BI Beans 3.2.3.0.x Release (3.2.3.0.37)

Persistence installation
========================

Connection information:

User / Schema: bibcat
Password     : bibcat
Host name    : xxxx
Port number  : 1521
SID          : o10gr2
Tablespace information:
System     :
Index      :
Attributes :
Clob       :

+++++     install/update D  D  L  (using GenerateDDL.java)
+++++     install/update (using biberrcs.pls)
+++++     install/update (using bibcnsts.pls)
+++++     install/update (using bibutils.pls and bibutilb.pls)
+++++     install/update (using bibacls.pls and bibaclb.pls)
+++++     install/update (using bibcores.pls and bibcoreb.pls)
+++++     install/update Associate (using bibascts.pls and bibasctb.pls)
+++++     install/update S e e d   D a t a (using bibpplt.sql)
+++++     install/update (bibexps.pls, bibexpb.pls, bibexpws.pls, bibexpwb.pls)
+++++     install/update Calcfilter (using bibcalcflts.pls and bibcalcfltb.pls)
+++++     install/update SYSTEM folder and PUBLIC group (using bibsys.sql)
+++++     Validating all installed packages
Package BISM_CALC_FILTER is invalid after installation!
+++++     install build version number: 3.2.3.0.37
+++++     D O N E

The error s shown here when installing the BI Beans Catalog. However, the same error can also come up when trying to install a D4O Catalog.



.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms