E1: JAS: Slow Performance on JAS Server when Number of Users Increases on System - WebSphere Application Server (Doc ID 1313821.1)

Last updated on MAY 30, 2017

Applies to:

JD Edwards EnterpriseOne Tools - Version 8.98 and later
Information in this document applies to any platform.

Symptoms

In this scenario here, you were previously on EnterpriseOne 8.11 and have just upgraded to EnterpriseOne 9.0 apps release level with IBM WebSphere as an Web Application Server. After a couple of hours and with more users logging in to the system, the application response times start to slow down until it becomes unusable.  It can take several minutes to log in to E1, users experience intermittently having the applications get stuck at "Processing" status for a few minutes before the application displays.  What used to take seconds before the upgrade now takes over a minute. The following errors appear in the JAS logs:

21 Mar 2011 09:16:33,283 [WARN ] - [BASE] ThreadPool:performWork: Threadgroup=OWVirtual_Thread_Group: No thread is available from the thread pool. Thread[Temporary Worker Thread - OWVirtual_Thread_Group18 Assigned To com.jdedwards.runtime.virtual.OWVirtual@61026102,5,OWVirtual_Thread_Group] is created to do the work..


Another symptom you have noticed is slowness in areas such as:  response time for logins is slower, navigating menus, accessing  HTML applications.  This occurs for a JAS server with two or more JVMs.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms