E1: MOB: Mobile Apps Setup. Error When Running The Script To Deploy The Shared Libraries (Doc ID 1468949.1)

Last updated on MAY 30, 2017

Applies to:

JD Edwards EnterpriseOne Mobile Requisition Self Service Approval - Version 9.0 and later
JD Edwards EnterpriseOne Mobile Sales Inquiry - Version 9.0 and later
JD Edwards EnterpriseOne Mobile Expense Management - Version 9.0 and later
JD Edwards EnterpriseOne Tools - Version 9.1 and later
JD Edwards EnterpriseOne Mobile Purchase Order Approval - Version 9.0 and later
Information in this document applies to any platform.

Symptoms

Application Version: JDE 9.1
Tools Release: 9.1.0.x
Application Server version: WLS 10.3.5.

As part of installing the JDE Mobile Applications, a JDECreateSharedLib.cmd script needs to be run. This script is provided via a package V30115-01 (for E1 9.1) and V29621-01 (for E1 9.0). These packages are available from Oracle Software Delivery Cloud (https://edelivery.oracle.com/).

You are following JD Edwards EnterpriseOne Mobile Applications Installation and Configuration Guide Release 9.0 and 9.1:
Section:  2.3  Creating and Deploying the EnterpriseOne Shared Library on WebLogic Server

ISSUE#1: 

When running the script as per the instructions in the Moblile Applications Installation guide, the script gives an error. On completion however, the status of the script says this was successful. The JDE.Shared.Lib. however is not shown in WLS "Deployments'' and it appears that he script filed to deploy the libraries.

Issue have been seen on both Windows and Linux:

a. On Windows, the DOS shell shows an error as follows:

 

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms