E1: DB: Junk Characters Are Inserted With Records In Tables Of AS400 During Upgrade On V7R1 or V7R2 Based Platform

(Doc ID 1967950.1)

Last updated on AUGUST 02, 2017

Applies to:

JD Edwards EnterpriseOne Tools - Version 8.98 and later
IBM i on POWER Systems

Symptoms

You are trying to do an application upgrade to E910, on a V7R2 based AS400 platform.
After doing the initial PS910 upgrade, it is found that the records in tables (SY910, OL910 etc) are padded with junk characters. You checked the records from application as well as DB2 tools, and confirmed that the physical tables are indeed having the junk values.
Any new record inserted into these tables are getting inserted along with the junk characters. It is not possible to clean up the records one by one to remove the junk characters.

This issue can also be reported in case of a new installation on V7R1 or V7R2 based platform.

The following screen shot shows how the junk characters are seen from application and DB2 utilities.

 

 




You have verified that the latest version of V7R1 AS400 Client access software for Windows is used to connect to the DB2 database. Even though the AS400 box is V7R2, we need to use V7R1 client access software, because IBM has not released client access software specific to V7R2.


Reference - http://www-03.ibm.com/systems/power/software/i/access/windows.html

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms