E1: AIS Client Password Issue

(Doc ID 2180287.1)

Last updated on MARCH 05, 2018

Applies to:

JD Edwards EnterpriseOne Tools - Version 9.1 and later
Information in this document applies to any platform.

Symptoms

If '&' symbol is used in credentials for accessing AIS orchestrator client it throws Authentication failure message. But if we are using same '&' symbol in credentials we can able to access JAS

Below is the error which can be found in the AIS logs.

"E1RestTokenServer jasAuthentication JAS ERROR OUTPUT: inputParams INPUT PARAMS: TEST-JDV920-*ALL-http://ENT92:8080 Exception Occurred Server returned
HTTP response code: 403 for URL: http://ENT92:8080/jde/FormServiceRequest java.io.IOException: Server returned HTTP response code: 403 for URL:
http://ENT92:8080/jde/FormServiceRequest"

 

STEPS TO REPRODUCE

==================
1) Create two user ID's in JDE 'TEST' and 'TEST1' where the password for 'TEST' is "TEST&" and the password for user 'TEST1' is "TEST1".

2) Through JDE everything seems to working fine but once we add these users under "Admin Service Allowed User List" of AIS Instance and try to
access with 'TEST' it is not working, but with user TEST1, it is working.

3) Now try changing the credentials to "TEST@" from 'TEST&' then you should be able to access but if we change it again to "TEST&" it doesn't work.

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms