My Oracle Support Banner

E1: AIS: REST Service Slow Performance and Getting Error InstanceNotFoundException and java.lang.NullPointerException in Weblogic Log (Doc ID 2731496.1)

Last updated on DECEMBER 08, 2020

Applies to:

JD Edwards EnterpriseOne Tools - Version 9.1 and later
Information in this document applies to any platform.

Symptoms

Customer has custom web application integrated with JDE through REST APIs via AIS. This external application getting very poor performance from AIS instances and noticed the following errors in Weblogic log very frequently:

 

 

Customer has 2 physical servers each hosting 3 AIS instances, each AIS instance has their own dedicated HTML instance.
AIS Server full Tools Release 9.2.3.4
HTML Server full Tools Release 9.2.3.4
WebLogic Server 12.2.1.2.0
SMC on 9.2.3.4


Restart was performed in the middle of the night while the number of users was low, but indeed as soon as more users were logging in to custom web app on IIS that do REST request, performance issues starting to be visible.
Apart from the high volume of error in the log mentioned, there are no other symptoms.
Pure JDE performance is fine including UBEs.
No orchestration has failed.
Only users accessing JDE via AIS are complaining about performance.

REST request is re-using token.
Each external app user is using its own credentials, not using a proxy user.


Changes

More users using the external application that send REST to AIS

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.