WS: WEB: Web Enablement Runtime Versions 6.0C6 and 4.x Unable to Configure for SSL; Not Compatible Using OpenSSL SHA2 Protocol (Doc ID 2041347.1)

Last updated on JULY 28, 2016

Applies to:

JD Edwards World Technical Foundation - Version A9.1 and later
Information in this document applies to any platform.

Symptoms

 After upgrading OpenSSL certificates from SHA1 cipher to SHA2 cipher, a connection to Web Enablement cannot be established when using Web Runtime Versions 6.0C6 or 4.x.

Changes

 The Windows server uses 0.9.8o version of OpenSSL that started supporting SHA2, but the Native (iSeries server) still uses 0.9.8e which does not support SHA2.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms