WebLogic Managed Server Terminates on Startup (Doc ID 1051972.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Weblogic Server - Version: 8.1 and later   [Release: and later ]
Generic UNIX

Symptoms

The startManagedWebLogic.sh script is not executing the Java command. After the echo statement, "Starting WLS with line:" and the echo statement preceeding that, the shell script exits. The java command to run weblogic.Server exits without any error. The following is printed in the stdout:

from start managed server: YES
.
.
JAVA Memory arguments: -Xms2560m -Xmx2560m -XX:MaxPermSize=512m -XX:NewSize=512m -XX:MaxNewSize=512m -XX:SurvivorRatio=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+UseTLAB
.
WLS Start Mode=Production
.
CLASSPATH=:/apps/bpmpr01/bea/patch_wlw1030/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/apps/bpmpr01/bea/patch_wls1030/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/apps/bpmpr01/bea/patch_cie660/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/apps/bpmpr01/bea/jdk160_05/lib/tools.jar:/apps/bpmpr01/bea/wlserver_10.3/server/lib/weblogic_sp.jar:/apps/bpmpr01/bea/wlserver_10.3/server/lib/weblogic.jar:/apps/bpmpr01/bea/modules/features/weblogic.server.modules_10.3.0.0.jar:/apps/bpmpr01/bea/wlserver_10.3/server/lib/webservices.jar:/apps/bpmpr01/bea/modules/org.apache.ant_1.6.5/lib/ant-all.jar:/apps/bpmpr01/bea/modules/net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar::/apps/bpmpr01/bea/wlserver_10.3/common/eval/pointbase/lib/pbclient57.jar:/apps/bpmpr01/bea/wlserver_10.3/server/lib/xqrl.jar::
.
PATH=/apps/bpmpr01/bea/wlserver_10.3/server/bin:/apps/bpmpr01/bea/modules/org.apache.ant_1.6.5/bin:/apps/bpmpr01/bea/jdk160_05/jre/bin:/apps/bpmpr01/bea/jdk160_05/bin:/usr/bin:
.
***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at http://hostname:port/console *
***************************************************
starting weblogic with Java version:
java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
Java HotSpot(TM) Server VM (build 10.0-b19, mixed mode)
Starting WLS with line:
/apps/bpmpr01/bea/jdk160_05/bin/java -server -Xms2560m -Xmx2560m -XX:MaxPermSize=512m -XX:NewSize=512m -XX:MaxNewSize=512m -XX:SurvivorRatio=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+UseTLAB -da -Dplatform.home=/apps/bpmpr01/bea/wlserver_10.3 -Dwls.home=/apps/bpmpr01/bea/wlserver_10.3/server -Dweblogic.home=/apps/bpmpr01/bea/wlserver_10.3/server -Dweblogic.management.discover=false -Dweblogic.management.server=t3://10.5.48.81:7001 -Dwlw.iterativeDev=false -Dwlw.testConsole=false -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/apps/bpmpr01/bea/patch_wlw1030/profiles/default/sysext_manifest_classpath:/apps/bpmpr01/bea/patch_wls1030/profiles/default/sysext_manifest_classpath:/apps/bpmpr01/bea/patch_cie660/profiles/default/sysext_manifest_classpath -Dweblogic.Name=MServer2 -Djava.security.policy=/apps/bpmpr01/bea/wlserver_10.3/server/lib/weblogic.policy weblogic.Server

The server does not hang; the script just exits with a success code. No failures reported. It's just that the java command fails to execute.


Changes

New application files were copied to the domain directory with a different userid.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms