My Oracle Support Banner

Unsupportedclassversionerror: Bad Version Number in .Class File when using Custom Code (Doc ID 1083908.1)

Last updated on JULY 21, 2020

Applies to:

Identity Manager - Version 9.1.0.1 and later
Information in this document applies to any platform.
Checked for relevance on 27-Jan-2012


Symptoms

Customized the adpMEXCCREATEMAILBOX adapter by creating a custom Java class and replaced the delivered remote manager adapter task.

However, getting the following error:
DEBUG 06 Apr 2010 14:56:02,162 [XELLERATE.ADAPTERS] - Class/Method: tcAdpEvent/updateSchItem - Data: event - Value: adpMEXCCREATEMAILBOX
DEBUG 06 Apr 2010 14:56:02,162 [XELLERATE.ADAPTERS] - Class/Method: tcAdpEvent/updateSchItem - Data: New Status - Value: R
DEBUG 06 Apr 2010 14:56:02,162 [XELLERATE.ADAPTERS] - Class/Method: tcAdpEvent/updateSchItem - Data: SchData - Value: Error occurred in server thread; nested exception is: java.lang.UnsupportedClassVersionError: Bad version number in .class file when the custom Java class fires.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.