My Oracle Support Banner

WebLogic Server Proxy Plug-In Support (Doc ID 1111903.1)

Last updated on APRIL 29, 2021

Applies to:

Oracle WebLogic Server - Version 9.2 and later
Information in this document applies to any platform.


Details

Applies to:

Note: This document does not apply to Oracle HTTP Server (OHS). For information on Oracle WebLogic Server Proxy Plug-In 1.1 support with Oracle HTTP Server 11g, see these documents:

Direction to Use Latest WebLogic Server 12c (12.2.1.4) Proxy Plug-Ins

As Oracle WebLogic Server 10.3.6 (and WLS Proxy Plug-Ins 11.1.1.9) versions approach the end of Premier and Extended Support, (refer to the Lifetime Support Policy), it is recommended to upgrade to WebLogic 12.2.1.4 (or later) in order to have the assurance of a long error correction timeline.

If using the WLS Proxy Plug-In with WebLogic Server 10.3.6, it is recommended to upgrade the WLS Proxy Plug-In to version 12.2.1.4. This is to allow use on Apache 2.4 and to maintain security updates. 

- IIS PLUGIN BUNDLE PATCH 12.2.1.4.210420 <Patch 32500025> or later
- APACHE PLUGIN BUNDLE PATCH 12.2.1.4.210420 <Patch 32499990> or later

 

Support Status for WebLogic Server Proxy-Plug-In for Apache 2.2

As announced by the Apache HTTP Server Project, Apache 2.2 has reached end-of-life. The WebLogic Server Proxy-Plug-In 11g (11.1.1.9) is no longer being maintained for usage with Apache 2.2, and no newer versions of the plugins will be certified with Apache 2.2. If using the WLS Proxy Plug-In with WebLogic Server 10.3.6, it is recommended to upgrade the WLS Proxy Plug-In to version 12.2.1.4. This is to allow use on Apache 2.4 and to maintain security updates.

Support Status for WebLogic Server Proxy-Plug-In for Oracle iPlanet Web Server

View the Lifetime Support Policy to see that all versions of Oracle iPlanet Web Server expired Premier and Extended Support. All versions are currently under Sustaining Support with no new updates available. This includes the WebLogic Server Proxy-Plug-In for the iPlanet Web Server. In addition, Oracle iPlanet Web Server has been deprecated from the Web-Tier 11g portfolio, reference <Note 1576588.1>, Oracle Web Tier - Statement of Direction.  It is recommended that Oracle iPlanet Web Server users migrate to a fully supported version of Oracle HTTP Server. The following documents are provided to assist in sustaining and upgrade tasks:

<Note 1371388.2> Information Center: Oracle iPlanet Web Server

<Note 1536893.1> Migrating From iPlanet Web Server to Oracle HTTP Server (OHS)


WebLogic Server 10g Proxy Plug-Ins (previously called version 1.0), WebLogic Server 11g Proxy Plug-Ins (previously called version 1.1), and WebLogic Server 12c Proxy Plug-Ins

This section provides an overview as the WebLogic Server transitions through different versions. The Oracle WebLogic Server Proxy Plug-Ins provide load balancing across WebLogic Server managed servers by acting as front-end proxies. They are written in native code, not Java, so they are specific to the operating system on which they are used. For this reason, they are not patched using the usual WLS procedures, they cannot be patched in the same way as Java code. Whenever a fix is needed to the plug-ins, this is accomplished not by patching but by a complete replacement of the native code with the new version.

Starting with WebLogic Server 11g, proxy plug-ins are given a version number that corresponds to a Fusion Middleware version number (11.1.1.x). This number replaces the numbering system which had been used previously. The proxy plug-ins for WLS prior to 11g, which were previously called version 1.0 plug-ins, have been renamed WebLogic Server 10g proxy plug-ins. Plug-ins for WLS 11g are now named WebLogic Server 11g proxy plug-ins, renamed from version 1.1 plug-ins. Plug-ins have also been released for WebLogic Server 12c. The 12c proxy plug-ins are certified for use with WebLogic Server 11g and WebLogic Server 12c. We recommend that all customers using a supported 64-bit webserver (see below) should use the latest 12c proxy plug-ins with WebLogic Server 11g and 12c.

Functional Differences

WLS 10g proxy plug-ins were packaged with WebLogic Server versions up to and including 10.3.x. However, 10g proxy plug-ins are NOT packaged with WebLogic Server 12c, and they should not be used with WLS 12c. The proxy plug-ins have always existed somewhat independently of WebLogic Server itself: the 10g proxy plug-ins work with any version of WLS up to 10.3.x, and a fix to the proxy plug-ins (replacing the plug-ins with the fixed version) also works with the same versions of WLS.

The WLS 11g proxy plug-ins enhance the functionality of the 10g proxy plug-ins and address some of the limitations of the version 1.0 proxy plug-ins. Highlights of enhanced functionality included in the 11g proxy plug-ins are:

The WLS 11g proxy plug-ins are optimized for use with WLS 11g, and are tested only with WLS 11g (WLS 10.3.1+). Because they are not tested with earlier versions of WLS, we cannot guarantee that new releases will work perfectly with older versions, but we expect that they will be backward-compatible with earlier WLS versions, with some limitations as described above. We encourage customers using a WLS version before 11g (10.3.0 and before) to upgrade WLS to 11g or higher so that they can use the proxy plug-in with the WLS version for which it has been optimized. Please refer to the plug-in documentation provided with WebLogic Server for details on functional support in the different plug-in versions.

Platform Support

The WLS 10g proxy plug-ins are designed to work with 32-bit Apache, iPlanet and IIS Web Servers and is supported on the following platforms: Linux, Solaris (SPARC, x86), AIX (POWER), and HP-UX (PA-RISC). The exact OS version is determined by the WLS 10g supported OS versions on these platforms.

The WLS 11g proxy plug-ins are designed to work with:

The WLS 12c proxy plug-ins are designed to work only with 64-bit Web Servers. This information is captured in the Fusion Middleware 12.1.2+ certification matrix (under the Web Server tab). The certifications matrix at http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html lists the web server versions and the operating system products and chip architectures that are supported by the proxy plug-ins.

For a given operating system product (such as Solaris) and chip architecture that is supported by a proxy plug-in, the proxy plug-in supports the same operating system versions (such as Solaris 10) that are supported by the WebLogic Server version you are connecting to. Refer to the WebLogic Server documentation for specific operating system version support. When proxying to multiple WebLogic Server versions from a single plug-in, the proxy plug-in is supported only on operating system versions that are supported by all of the WebLogic Server versions that the plug-in is connecting to.

Physical Packaging

The WLS 10g proxy plug-ins are bundled with WebLogic Server installers for WLS versions through 10.3.6. WLS 11g and higher proxy plug-ins are not bundled with WebLogic Server installers, and no proxy plug-ins at all are bundled with WebLogic Server 12c (versions 12.1.1 and higher). Instead, the proxy plug-ins are made available separately for download and installation. Please see instructions below for downloading the latest maintenance releases for the WLS 10g and WLS 11g and higher proxy plug-ins.

Downloading Latest 10g Proxy Plug-ins

The latest maintenance releases for the proxy plug-ins are available for download. For the WLS 10g proxy plug-ins, download the latest release from <Patch 10051798> on My Oracle Support. For the WLS 11g and 12c proxy plug-ins, download the latest release from Oracle Technology Network (OTN) at http://www.oracle.com/technetwork/middleware/webtier/downloads/index.htmlThe traditional WLS 10g (version 1.0) proxy plug-ins have been deprecated, meaning that WebLogic Server versions beyond 11gR1 (including WebLogic Server 12c, 12.1.1 and higher) are not supported by the WLS 10g proxy plug-ins. Premier Support for WLS 10g proxy plug-ins has expired for all versions. Given the improved functionality available in the WLS 11g and higher proxy plug-ins, we encourage customers to use the WLS 11g or higher proxy plug-ins when possible in applicable projects.

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
 Direction to Use Latest WebLogic Server 12c (12.2.1.4) Proxy Plug-Ins
 Support Status for WebLogic Server Proxy-Plug-In for Apache 2.2
 Support Status for WebLogic Server Proxy-Plug-In for Oracle iPlanet Web Server
 WebLogic Server 10g Proxy Plug-Ins (previously called version 1.0), WebLogic Server 11g Proxy Plug-Ins (previously called version 1.1), and WebLogic Server 12c Proxy Plug-Ins
 Functional Differences
 Platform Support
 Physical Packaging
 Downloading Latest 10g Proxy Plug-ins
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.