My Oracle Support Banner

Error Seen When Running an Essbase Interface in ODI Using an ODI Agent Service: com.hyperion.odi.essbase.ODIEssbaseException: Error occurred while executing a maxl script (Unknown Source) (Doc ID 1152893.1)

Last updated on JANUARY 30, 2022

Applies to:

Oracle Data Integrator - Version 10.1.3.4.5 and later
Hyperion Essbase - Version 9.3.1.0.00 and later
Information in this document applies to any platform.

Symptoms

  • When the ODI agent is running as a Windows service and an Essbase interface in ODI is run,  an error like the following is seen:

 

  • If an ODI Agent is manually started by using the agent.bat script in <ORACLE HOME>\oracedi\bin\agent.bat  then the integration succeeds.
  • Please note: If this does not work when using a standalone ODI Agent either then please check that the Essbase client has been installed on the machine where the ODI Agent is running. The Essbase KM User Guide (default location - C:\OraHome_1\oracledi\doc\km\odiess_users.pdf) states that this is a pre-requisite for using MAXL scripts.

Changes

Either:

1. The ODI Agent is running as a Windows service under a system account.

2. The ODI Agent is running in OPMN.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
 Check that the Essbase Client Has Been Installed
 If the ODI Agent is Running as a Windows Service
 If the ODI Agent is Running Under & Being Managed by OPMN (Possible in ODI 11.1.1.3.00 and higher)
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.