My Oracle Support Banner

Running Oidca (or Netca) from a 10g or Higher Database Home Fails with: OID Server version is incorrect OR Cannot connect to OID server (Doc ID 1168924.1)

Last updated on OCTOBER 01, 2019

Applies to:

Oracle Internet Directory - Version 9.0.4 and later
Information in this document applies to any platform.

Symptoms

Running oidca (or netca) tool to add an Oracle Context to Oracle Internet Directory (OID) 11g repository, either from a 10g OID home or from a 10g or 11g Database home ($ORACLE_HOME/bin/oidca), returns the following message:

OID Server version is incorrect

Alternatively, the following error can occur against OID 11g instead:

Cannot connect to OID server.


Example of oidca command:

oidca mode=CREATECTX -silent oidhost=<OID_HOSTNAME> nonsslport=<OID_LDAP_NONSSL_PORT> sslport=<OID_LDAP_SSL_PORT> dn=cn=orcladmin pwd=<PASSWORD> contextdn=cn=OracleContext,dc=<REALM2>,dc=com

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.