OWB 11g Table Upgrade Deployment Fails With libocijdbc11.so: wrong ELF class: ELFCLASS64

(Doc ID 1170643.1)

Last updated on MAY 09, 2017

Applies to:

Oracle Warehouse Builder - Version 11.1.0.6 to 11.2.0.1 [Release 11.1 to 11.2]
Information in this document applies to any platform.

Symptoms

The deployment of a  table "upgrade" will fail with the following message:

/opt/app/oracle/product/11.2/lib/libocijdbc11.so: ld.so.1: java: fatal: /opt/app/oracle/product/11.2/lib/libocijdbc11.so: wrong ELF class: ELFCLASS64

Changes

For OWB 11.2.0.1, <Patch 9092437> has been applied but did not fix the issue.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms