WLW 10.3: Upgrade from WLW 8.1 results in RuntimeException with Expressionevaluator "Compat-Netuiel" specified but Expressionenginefactory not found. (Doc ID 1191205.1)

Last updated on DECEMBER 03, 2012

Applies to:

Oracle Workshop for Weblogic - Version: 10.3 to 10.3 - Release: AS10gR3 to AS10gR3
Information in this document applies to any platform.

Symptoms

When using Workshop's import wizard to upgrade custom application from WLW 8.1.5 to WLW 10.3 it is noticed that the generated application runs but JSP pages fails to display. The error page with a NullPointerException is displayed instead. The console displays the error "java.lang.RuntimeException: The default ExpressionEvaluator named "compat-netuiel" was specified, but the ExpressionEngineFactory could not be found."

As per beehive.netui-config.xml the below is included:
<expression-languages>
<default-language>compat-netuiel</default-language>
<expression-language>
<name>netuiel</name>
<factory-class>org.apache.beehive.netui.script.el.ExpressionEvaluatorImpl$NetUIELEngineFactory</factory-class>
</expression-language>
<expression-language>
<name>compat-netuiel</name>
<factory-class>com.bea.wlw.netui.script.el.ExpressionEvaluatorImp$NetUIELEngineFactory</factory-class>
</expression-language>
</expression-languages>

The specified class 'com.bea.wlw.netui.script.el.ExpressionEvaluatorImp$NetUIELEngineFactory', is available in WEB-INF/lib/workshop-netui-compat.jar

Why doesn't the upgraded application work?
Note the stack trace for more information:
java.lang.RuntimeException: The default ExpressionEvaluator named "compat-netuiel" was specified, but the ExpressionEngineFactory could not be found.
at org.apache.beehive.netui.script.ExpressionEvaluatorFactory.initialize(ExpressionEvaluatorFactory.java:142)
at org.apache.beehive.netui.script.ExpressionEvaluatorFactory.<clinit>(ExpressionEvaluatorFactory.java:47)
at org.apache.beehive.netui.pageflow.ProcessPopulate.populate(ProcessPopulate.java:169)
at org.apache.beehive.netui.pageflow.PageFlowRequestProcessor.processPopulate(PageFlowRequestProcessor.java:329)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:254)
at org.apache.beehive.netui.pageflow.PageFlowRequestProcessor.processInternal(PageFlowRequestProcessor.java:556)

Changes

WLW 8.1 application upgrade to WLW 10.3.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms