My Oracle Support Banner

Installing Webcenter 11g PS2 BP2 Get an Error: OUI-67074 (Doc ID 1203634.1)

Last updated on NOVEMBER 22, 2016

Applies to:

Oracle WebCenter Portal - Version 11.1.1.3.0 to 11.1.1.6.0 [Release 11g]
Information in this document applies to any platform.
***Checked for relevance on 14-Nov-2012***

Symptoms

 

Although this particular issue was encountered (and thus the information documented in this article) in WebCenter PS2 BP2, it could also be relevant to other WebCenter versions / patchsets / bundled patches.

 

The Readme for Webcenter 11g PS2 BP2 (<Patch 10040309>) states:

"(...) The user would be prompted for the following inputs by OPatch
to complete the auto patch application process.

AdminUser : Please enter the WebLogic Admin Server username
AdminPassword : Please enter the WebLogic Admin Server password
AdminServerURL : Please enter the WebLogic Admin Server URL
DomainHome : Please enter the WebLogic domain directory location
ApplicationsDir : Please enter the WebLogic applications directory location
default location is : MW_HOME/user_projects/applications/DOMAIN_NAME
NodeManagerUser : Please enter the NodeManager username
NodeManagerPassword : Please enter the NodeManager password

Please ensure input values are exact & correct to avoid undesired patch failures (...)"

 

However, there is no prompt for the NodeManager username/password.

Additionally, when trying to install this patch, opatch fails with error 74

SEVERE:OUI-67074:ApplySession failed during prerequisite checks: FMW Prerequisite check "preReq_Deploy" failed to execute - (WLST Error = 1)

 
The OPatch logs show:

INFO:Problem invoking WLST - Traceback (innermost last):
INFO: File "/u01/app/oracle/wls11gP1/Oracle_WC1/OPatch/fmw/main_driver.py", line 214, in ?
INFO: File "/u01/app/oracle/wls11gP1/Oracle_WC1/OPatch/fmw/prereq.py", line 293, in prereq_Deploy
INFO:TypeError: __init__() takes at least 4 arguments (2 given)
INFO:
INFO:Command invocation returned Error... '', Return Code = 1
INFO:FMW Prerequisite check "preReq_Deploy" failed to execute - (WLST Error = 1)
[
There was a problem in executing the OPatch Fusion Middleware WLST scripts.
Please refer to the log file for more details.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.