WLS 10.3: Web Service Failed to Deploy After Restarting WebLogic Server with Error Message BEA-149231 (Doc ID 1206912.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle WebLogic Server - Version 10.3 to 10.3
Information in this document applies to any platform.

Symptoms

Deployment of Webservice app works when deployed by the admin console, but once the server restarts the Webservice app-deployment fails with below exception:

ERROR
-----------------------
<Jul 26, 2010 1:56:49 PM EDT> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to
true for the application 'soapTest'.
weblogic.application.ModuleException: [HTTP:101216]Servlet: "TestServlet" failed to preload on startup in
Web application: "soapTest".
java.lang.IllegalArgumentException
      at com.sun.xml.bind.api.TypeReference.<init>(TypeReference.java:81)
      at com.sun.xml.ws.model.RuntimeModeler.processDocWrappedMethod(RuntimeModeler.java:660)
      at com.sun.xml.ws.model.RuntimeModeler.processMethod(RuntimeModeler.java:581)
      at com.sun.xml.ws.model.RuntimeModeler.processClass(RuntimeModeler.java:404)
      at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:260)
      at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:322)

Changes

None.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms