Xpath Query String Returns Zero Node (Doc ID 1221085.1)

Last updated on OCTOBER 25, 2016

Applies to:

Oracle SOA Suite - Version 11.1.1.2.0 to 11.1.1.3.0 [Release 11gR1]
Information in this document applies to any platform.
***Checked for relevance on 11-Jun-2012***
***Checked for relevance on 12-November-2013***

Symptoms

A BPEL component has around 500 activities. This issue happens intermittently at a specific point in the process.
As per analysis when it is performing a copy operation in an assign activity after a couple of copy operations it is truncating the updating variable returning ZERO NODE.

This is the error shown:

[2010-05-17T08:06:03.126-04:00] [WLS_SOA1] [ERROR] [] [oracle.soa.bpel.engine.xml] [tid: orabpel.engine.pool-4.thread-16] [userId: <anonymous>] [ecid: 0000IYa92pb7Q9x5KByWMe1BuSum0000Yt,0:1:0x5f5e8f4:1:0x5f5e8f5:1:0x5f5e8f8:1:0x5f5e900:1:0x5f5e901:1:100002050] [APP: soa-infra] com.oracle.bpel.client.BPELFault: faultName: {{http://schemas.xmlsoap.org/ws/2003/03/business-process/}selectionFailure}[[
parts: {{
summary=<summary>XPath query string returns zero node.
The assign activity of the to node query is returning zero node.
Either the to node data or the xpath query in the to node was invalid.
According to BPEL4WS spec 1.1 section 14.3, verify the to node value at line number 1994 in the BPEL source.
</summary>



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms